Back
Browser and OS Requirements
Subscribe by RSS
Share page by email
Save as PDF
Share
Alma User Interface – General Information Viewing System Status and Maintenance Announcements
As a true cloud solution, Alma requires only a browser for the end user. Alma supports all the leading browsers: Chrome, Firefox and Internet Explorer. There is an ongoing process of monitoring new browser versions and checking their compatibility with Alma. Full browser support details are noted below.
Ex Libris recommends that you do not work with Alma or Alma related products like Leganto in multiple tabs of the same browser. To work with Alma in multiple tabs, open each tab in a different browser (e.g., one tab in Chrome and the other in Firefox).
Browser Display Resolutions and Other Requirements
The Alma user interface is designed to work with the following screen resolutions and monitors:
Most Alma cookies are removed at the end of your browser session. For general information about Ex Libris cookies, see here.
Browser Certification
Ex Libris’ browser certification policy is based on industry usage statistics.
The following table describes the certified browsers:
Certified Browsers
BrowserDescription
Microsoft® Internet Explorer®
Starting from March 2021 release, Alma no longer supports the Internet Explorer® browser, including no longer fixing potential display and performance issues on IE.
Microsoft® EdgeMicrosoft® Edge is certified as a successor for Internet Explorer®.

Ex Libris makes every effort to test and certify the most recent stable version of Edge on an ongoing basis.
Mozilla® Firefox®Ex Libris makes every effort to test and certify the most recent stable version of Firefox on an ongoing basis.
In addition, Mozilla offers an Extended Support Release (ESR), based on the official release of Firefox for desktops, for use by organizations—including schools, universities, businesses, and others who need extended support for mass deployments.
Ex Libris will make every effort to test and certify the latest ESR version, after the overlap period between the older and newer ESR version is over.
Google Chrome™As with Firefox, Ex Libris makes every effort to test and certify the most recent stable version of Chrome™ on an ongoing basis.
Google Chrome applies updates automatically.
Browser Versions Not Certified
Ex Libris may discontinue certifying a certain browser version based on its industry usage. Issues reported that are specific to a browser version that has been discontinued will not be actively investigated or corrected.
Ex Libris gives prior notice when certification of a browser version is discontinued.
OS Requirements
If you are using Safari on an iPad, Alma is supported on iOS 11 or later.
Back to top
Alma User Interface – General Information Viewing System Status and Maintenance Announcements
Was this article helpful?
Term of UsePrivacy Policy
Cookie PreferencesContact Us
2021 Ex Libris. All rights reserved
Home Alma Product Documentation Alma Online Help (English) Getting Started
Browser Display Resolutions and Other RequirementsBrowser CertificationBrowser Versions Not CertifiedOS Requirements