MARAPRSEP
15
200920102011
7 captures
15 Apr 2010 - 29 Aug 2011
About this capture
Sign in

Help forumFeed
Help forum > Google News > Google News Publishers - Sitemaps > Missing XML Tag - What is missing?
Missing XML Tag - What is missing?
Report abuse
waitetom
Level 1
3/30/10
Hello.
I am having problems with out websites Google News sitmap.
We use Drupal and there is a module to create the sitemap.
When we submit the sitemap to Google we're getting the following Errors:


Missing XML tag
This required tag is missing. Please add it and resubmit.
Parent tag: urlset
Tag: url
Problem detected on: Mar 29, 2010

Do you know what this could be? Our sitemap is here: http://www.bingoparadise.co.​uk/googlenews.xml

Any help is really appreciated.
Thanks
Tom
Replies 1 - 9 of 9
methode
Top Contributor
3/30/10
Have you found the missing tag?

Did you find this answer helpful? Sign in to vote. Report abuse
waitetom
Level 1
3/30/10
No. I do not know what the missing tag is.
Do you?
Thanks for your response.
Tom
Did you find this answer helpful? Sign in to vote. Report abuse
methode
Top Contributor
3/30/10
This is odd. The current version of the sitemap has all the required tags.

Are you sure you supplied for Webmaster Tools the correct location of the sitemap?
Did you find this answer helpful? Sign in to vote. Report abuse
waitetom
Level 1
3/30/10
I am absolutely certain that I did.
Also what I find odd is, if I look at my sitemap in Firefox I get this message in the top of the browser:
'This XML file does not appear to have any style information associated with it. The document tree is shown below.'

Whereas if I look at the sitemap in IE the top lines appear in place (the lines below do not appear in Firefox):

<?xml version="1.0" encoding="UTF-8" ?>
- <urlset xmlns​="​http://www.sitemaps.​org/schemas/sitemap/0.9​" xmlns:n​="​http://www.google.​com/schemas/sitemap-news/0.9​"​>​'

I do not understand what is causing this problem.

Have you any further suggestions?
Thanks
-Tom
Did you find this answer helpful? Sign in to vote. Report abuse
methode
Top Contributor
3/31/10
The styling is something else, don't worry about it.

Rest assured that I didn't forget your issue, I just have nothing to report yet
1 of 1 people found this answer helpful. Did you? Sign in to vote. Report abuse
waitetom
Level 1
3/31/10
Thank you very much for taking the time to become involved in searching for answers to my, and other peoples technical issues!
It's appreciated.
-Tom
Did you find this answer helpful? Sign in to vote. Report abuse
methode
Top Contributor
4/1/10
Tom, could you take a screenshot of what you say and send it through my profile, please?
I have to show it for somebody.
Did you find this answer helpful? Sign in to vote. Report abuse
mrtyson
Level 1
4/2/10
I'm using the same module. Before submitting to SEs, I've been checking the specification for sitemaps over at sitemaps.org. I used this module a few years ago and seem to remember there being some coding standard issues with the files it generates, but I may be wrong.

The thing that really jumps out at me is that, at the top of your file and mine, they seem to be missing the top tag:
<?xml version="1.0" encoding="UTF-8"?>

Is this something that would cause this error? I've been searching around trying to find something on this topic but haven't been able to.

I'm not too up to speed on XML so I'm really just grasping at straws here.

Michael
Did you find this answer helpful? Sign in to vote. Report abuse
methode
Top Contributor
4/3/10
Hi Michael,

Even though the Sitemaps specification says the XML start tag should be present, Google will happily accept a feed without it.
In Tom's case Webmaster Tools reported that an URL tag was missing, which in fact was there.
Did you find this answer helpful? Sign in to vote. Report abuse
Post reply
Sign in to answer this question.
Subscribe
Receive email alerts when new replies are posted
Subscribe to the feed for this discussion
Go to:
Tell us how we're doing: Please answer a few questions about your experience to help us improve our Help Center.
Related discussions
Google News Not Indexing My URLs
8 replies
Having Trouble With Google News Missing My News Articles
2 replies
If my news sitemap meets all the requirements and is uploaded correctly - why are none of my articles indexed?
5 replies
Site stopped appearing in Google News since Sept 3rd
9 replies
Incorrect namespace Your Sitemap or Sitemap index file doesn't properly declare the name
3 replies
Unexpected publication name
9 replies
Parsing Error in my Google News Sitemap file -- not able to resolve
Answered (10 replies)
Boogled again - Missing Articles at Random
54 replies
Most of our exclusive stories are missed or indexing late in Google News search
20 replies
Google News - Help with other Google products - Getting Started guide
© 2010 Google - Privacy Policy - Terms of Service
Help articlesHelp forumPost a question